Troubleshooting "data duplication" problem caused by cloud syncing feature in v6.2


Well for me the new 6.2.1 update has broken things AGAIN!

I had finally cleaned up after all the duplication mess. 3 times I went through over 250 files and deleted a bunch of replicas only to have them come back again, twice. Finally got it all stable and one copy of everything.

I’m no longer sure if my data is being copied to iCloud. I don’t seem to have any visibility of it in iCloud any more. The notesplus-beta folder isn’t being used any more but there doesn’t seem to be any replacement, and if I look under the manage data in iCloud settings, it doesn’t show NotesPlus as using any data.

Today I got a new 6.2.1 update so nervously started NotesPlus.

Another scanning process. At least this one is faster and doesn’t seem to create any duplicates. However it does seem to have hung on one final file (it was at 99%) which it never seems to complete after some hours in the background and restarting multiple times.

Even worse though is that NotesPlus is now crashing on a regular basis as I am writing notes … and losing the last few minutes of data in the process.

This is hugely frustrating!


Hi Cameron,

Could you please try to restart your iPad, then check if the app is still crashing? There is a button to run the data migration in the background also the Notes Plus folder should be visible under on your iPad, could you check if the data is being updated?


Hi, I had the same feeling too. i switched also to goodsnotes and i still miss some good points in Notes plus but as you said, the support that of the app by the developers is very minimum. I hope they hire more people to improve it quickly.

1 Like

Thanks for the response.

I restarted my iPad. Yes, the app is still crashing – at least 3 times in about 4 hours of use since I restarted, losing around 5 mins work each time.

That one notebook that is still being processed by the conversion/update routine still has not finished. Yes I can run it in the background but it’s still going - probably 8 hours of run time now. The rest all seemed to process very quickly.

Surprisingly the Notes Plus Beta folder is back visible in the Files app now. It wasn’t there the last time I looked – I guess this was fixed in a recent update? I can see this through Finder on my Mac as well, so I’m comfortable the iCloud sync is working thanks.

The other issue that seems to have got worse in recent releases is when the Close-up writing window is out of synch with the content on the main page. Sometimes in a new document the close-up window will display data from the old window. Sometimes it displays data from earlier in the same document. Moving the grey indicator box doesn’t fix it – usually closing then re-opening close-up mode will fix, but one time I actually had to exit the notebook. I have seen others complain about this issue so I guess you’re aware of it, but it seems to have gotten worse.


Another 4-5 crashes in the next couple of hours of use.
Make that 8-10 in the next 3-4 hours of use.
Make that DOZENS of crashes over the last 2 days. This is driving me crazy!

Could it be related to the fact that this one notebook is still trying to be converted? Every time I restart, the dialog pops up for converting that one file, I send it to background and it keeps running. Days later it has yet to complete.

There seems to be some link between when the close-up window gets out of sync and the crashes. Often the crash comes immediately after the window is out of sync.

1 Like

Same problem, app hangs on one file update, then crashes spontaneously, causing loss of notes. Very unstable. Also crashes spontaneously while attempting to import photos from the photos app.

1 Like

Same here, Cameron and Turningpointtom. The update routine is operating and it got to 77% the first time, and froze. I restarted, and since then, the app has started a dozen different times and gets to varying degrees of completion (it’s not always in view) and the app crashes eventually. Thankfully it doesn’t look like it’s duplicating all the files. But still… what a freakin’ mess. I’m trying to get in there and export all my stuff out of Notes Plus and into Good Notes, so I can stop wasting endless hours of time.

Oh… here it goes again, live, as I type… How fun! “Updating notebook data.” Let’s see how far it gets. So far it’s sitting at 0%… oh, now it’s slowly moving… 6%… any bets on what % crashes it? (I know you all aren’t here in real time but it’s fun to imagine we’re all watching this circus together. LOL)

Okay… it’s been 9 minutes and it hung at 14%… I’ll let it sit here a while, but I’m going to post this comment… so you’ll never know for sure what happens. But I bet you could guess! :wink:

Sigh. Good luck everyone. Hope they help you figure this out and you don’t lose your data.


1 Like

AWWWWW… anyone that guessed 42%… you WIN! The app just crashed.

1 Like

@duynguyen did you see my response on the debugging steps you requested 5 days ago? Any follow up? Any further steps to debug why this one notebook never finishes converting and whether that’s related to the crashing and data loss issues?

Clearly this is not a problem isolated to me. Perhaps you’ve already reproduced / isolated the problem and are working on a fix?


@duynguyen any update? I did the debugging steps you asked 8 days ago now.


I’m having some of the same problems and every time I try the suggestions by developer to retrieve my notes, I lose more. Duplicates still happening. Seems such a shame that this update and the updates that followed to correct update have not helped.
I’ve gone to GoodNotes and although it’s as smooth and erasing isn’t as easy, so far I’m not having the glitches I had with Nite Plus. I absolutely loved this app. Now just frustrated over two years of info gone.

1 Like

Same here! Everything is screwed up and I have lost access to years of notes, and have a nicely organised notebook filled with duplicates! Hopefully the fix will be released soon.


Do you plan on answering any of our questions or have you just abandoned all who use this app and lost years of work?

1 Like

Dear all,

Sorry for providing support on the forum slowly on these days. We’re regret about recent issues with iCloud. Let me give you an overview of these issues so you have a better understanding what is going on.

​Regarding some recent issues, they are related to iCloud and our data migration tool. Some months ago, our team realized our old resource file format wasn’t working well with iOS Storage Optimization (when enabled iCloud Drive) and the system would evict your files from local to iCloud server when the device is in low storage or under some circumstances (Apple doesn’t tell the transparent process how this logic works). When some of our resource files were evicted to the cloud server, the app couldn’t render notebook content on the page properly. Thus, we decided to move to new file format.

This required the data migration to take in place. However, iCloud occasionally got stuck during the data migration for many users and that caused the notebooks couldn’t be transfered to new file format properly. As a result, instead of showing your actual notebooks, some of those items are now shown as resource folder with .xml, .js, html, etc… Even worse, your files/folders are being duplicated multiple times. After scanning through our code, we eventually found out the data duplication was not coming from our data migration code entirely, but it was partly with iCloud service itself when it came to manipulate a lot of resource files in a short time.

There are times iCloud couldn’t “see” the files already saved on local storage and the other time the app couldn’t fetch the file existence state on iCloud server, thus it would create extra copies of a notebook. This leads to #1 and make the app running slowly and it could cause crashes when iOS run out of system resource. Unfortunately, for such events, the app couldn’t detect and remove extra copies automatically. Instead, please try to clean up your library manually in these steps: On your iPad, return to home screen, open, go to iCloud Drive > Notes Plus > find the extra copies (in .npn format), now tap “Select” button at the upper right corner, select the items, tap “Delete”. In case you delete a wrong item, you can go to “Recently Deleted” section in at the left sidebar, restore the deleted items.

​After the migration process has been completed, the data duplication issue should not happen anymore.

When we supported users with the iCloud-related issues, some users confirmed they could get back to normal state after turned off iCloud and re-link with iCloud sync (remember to choose “Not to keep the data on the device” when asked so your data won’t be duplicated if you enabled iCloud syncing again).

Since there are many users encountered different migration results, we couldn’t give support to your specific cases on this single thread. Kindly redirect your specific issues with some contexts (which cloud service/what is the symptom, etc…), the more details you provide the easier we could help you. Our support email is:

We’re committed to fix whatever left from our releases to bring back stability. Our Dev Team is still fixing bugs from our end and work on iPadOS bug fixes.



Thanks for the update.
My problems are 1bout 95% solved.
Another byproduct I’m seeing is a “phantom” notebook that can’t be selected or deleted and have (0) as the number of pages.
How do I get rid f those?


So on the day before @duynguyen returned to the forums I gave up on waiting for support to give any solutions and decided I better try to solve my problems myself.

For over 3 weeks, I had one notebook stuck in the conversion process that would pop up showing the ongoing conversion each time I restarted NotesPlus. I would send it to background, but it never finished.

Meanwhile I was suffering crashes, each time losing maybe 10 minutes of writing, several times per day.

Eventually I decided to just delete that one notebook that was stuck in conversion. And it’s fixed the problems for me. No more prompts about conversion. Most importantly, no more crashes and data loss in the last 3 days.

So yes, for me, the crashing was absolutely related to that conversion ongoing in the background. Maybe the conversion routine has a memory leak or something?

I know there were others in that same situation of one stuck conversion and crashes. So if you can afford to lose that one document, or you have a backup of it, then you might try deleting it.

Best of luck!


Thanks for posting useful actions to take that can help correct problems, Cameron. I wish the Dev and Support teams would try that, instead of copying and pasting the same explanation of what happened. We all know the back story… what we need is help to fix the problem.

I hope others have luck with getting things worked out.

1 Like

Thanks for the feedback. Because some users didn’t know what happened so I though I should post it across the board and users know what has happened. For specific support request, I think it’s best to contact our Support team at and we can provide appropriate support solutions for each case.


I use Dropbox for back up. The file extensions in Dropbox are now a smattering of .html, .xml, .svg, and .npn files. The task queue is over 16k while counting up, once it starts working back down it gets to 16331 and the app crashes. None of the suggestions in this thread help. Is there a way to clean this up outside the app? Is there away to get the old version of the app back?


I’ve found all my notes on iCloud on my computer. I went and saved them all before I did anything else. Some I got back in app but others I just can’t seem to get to go back or into any other app.