This might help recover lost notes

#1

No guarantees, but this may help if you can’t access your notes on the app. It worked for me.
A number of my files were corrupted in that when I opened a folder it displayed a list of numbered folders & a resources folder, all of which contained blank content.
I backed this content up to iCloud.
On my pc I opened File Explorer and opened my iCloud Drive (not via iCloud.com)
When I opened my Notes Plus folder (backed up to iCloud Drive) I still had the folders displaying as though corrupted but when I opened the numbered folders, they then contained a resource folder each and inside those resource folders I was able to view the file content.
I hope this helps some of you out.
Let me know.

#2

I am getting this problem over a total of 5 years worth of notes. Nothing is fixing it. New notebooks (made in the last couple of weeks) seem to be ok.

#3

I noticed the same problem after the latest update (v. 6.4). As with you, all the affected notebooks are still present on the online backup (Dropbox in my case), and can be read on a computer by opening the .svg image file for each page of each note.

In principle, it is possible to manually convert each .svg image to a pdf and then stitch each notebook back together as a single pdf file and re-import to NP, but I have dozens of affected notebooks and would really really really like to avoid having to do this

Upon closer inspection, I noticed that all affected notebooks did not have the .npn suffix in their filenames. As far as I understand, this means that they are still in a format used by older versions of NP (pre-‘Great Duplication Catastrophe’). I have tried running the ‘Data Migration’ tool found in the NP Settings, which promises to convert the data to the new format, but nothing seems to happen.

My hope is that the developers make the old format readable again in a future update, or fix the migration tool. I have written to them to ask for this, no great hopes though.

Lost all the notes after upgrade to 6.4 - SOS
Notes disappeared
#4

I emailed support [support@notesplusapp.com] and they actually replied quickly and with an effective solution

Step-by-step

  1. Enable a cloud backup (if you haven’t already) and sync.

  2. Close the NP app on your iPad

  3. Access your cloud backup (ideally, via a PC/Mac) and rename all notebook folders lacking an .npn suffix (just add this suffix to the folder names)

  4. connect your iPad to your computer and access it via iTunes or Finder. Look for the file sharing menu. Drag the renamed folders onto the Notes Plus folder to get them back on the iPad.

  5. Open the Files app on your iPad. Look for the newly moved notebooks on the main folder of the Notes Plus app. Move them into the correct subfolders, if necessary.

  6. Open Notes Plus. Your notebooks should be accessible!

#5

Did this actually work for you? When I do this, the notebook is indeed readable by notesplus, but only the first page is OK - the rest are corrupted (text is jumbled around, and you can only see the top left corner of each page).

#6

Yes it did work for me. I did not experience the problem you describe. All my notebooks are fine (for now)

As other posters have remarked, maybe you need(ed?) to give Dropbox / Icloud time to sync properly before moving the files onto the iPad?
Good luck.

#7

Thanks for the response.

It’s been well over a week and nothing has changed as far as I can tell. Also I have all my notebooks are backed up both on icloud and dropbox (these are mostly old notebooks, from years ago), and this behavior applies to both sets of backups (which are identical as far as I can tell).

One thing that might make me unusual is that I didn’t upgrade for a long time, so I upgraded all the way from a version that was maybe two years old to the current one?