Notes Plus Beta Folder not showing in iCloud on Non-iOS Devices

#1

I have only just now moved from 6.0 to 6.2.1. (I am also migrating from an older iPad to a newer one. So I have two iOS devices connecting to iCloud for Auto Backup).

Within the Files App on both iPads I can see the ‘Notes Plus Beta’ folder in iCloud. And looking at iCloud Storage in iOS Settings shows my notebooks stored on iCloud Drive.

When I attempt to access these files from either a PC,Mac (With iCloud Drive inside File Explorer/Finder) or via iCloud Drive inside an Internet Browser I do not see the Notes Plus Beta Folder.

It is probably coincidence but the issue seems to have started when I was restoring a new iPad from an iTunes backup and when I tried to run Notes Plus on the new iPad ( was version 6.0) which had iCloud Backup turned on for the system that was being restored from… The app would just hang. I have about 1.5 GB of Notebooks stored on iCloud.

After attempting numerous times to make the new iPad work with Notes Plus and having it hang ( or do nothing without telling me what it was doing???), I decided to go back to the older iPad after shutting the new one down.

On the older iPad I went ahead and updated to 6.2.1 and the process of converting the library went pretty quickly( a few minutes) but the process of uploading the files back up to iCloud took a long while (hours) despite having gigabit fiber ( 1gbps up and down).

So all that seems to have gone well and the new .npn files on iCloud all look good and downloaded to the new iPad after I updated it to 6.2.1 also(using Auto-Download).

So I know things are all working as far as data being sent to iCloud and brought down from iCloud, but I just can’t see the Notes Plus Beta folder on a non iOS device. I have tried both Mac and PC systems with newest software on both of them as well as Browsing to iCloud.com and in each of these cases there is no sign of the Notes Plus Beta folder.

Certainly happy to report that I did not have problems with data migration(duplicates) by holding off from updating from 6.0 til 6.2.1 was ready.

1 Like
#2

Hi @sherwoods,

Regarding the issue with Notes Plus folder doesn’t show up on your non-iOS device. That’s weird because macOS/Web version should be reflected what you see in iCloud Drive on iPad. If you open Files.app on your iPad, go to iCloud Drive > Notes Plus, do you see .npn files have been synced completely (not stuck with “Waiting for Update”)? I think the iCloud web version has some troubles when it loads a list of long files. That’s not a thing we can manage from our own side, usually such a thing may be resolved when re-link with iCloud, however the process would take quite some time if your iCloud has a lot of files on other apps. We don’t have good experiencing with the process of restoring files through iCloud so we’d not recommend to reset the iCloud.

One thing you may check, if you open iPad’s Settings > Apple ID > iCloud > Manage Storage > what’s the used storage data from Notes Plus there?

#3

Thanks for the reply. So I see 1.6GB iCloud Storage used for Notes Plus on my iPad. Of course that is not how it looked a day or so before I sent the last message. At that earlier time I only saw a small amount of space being used and the iCloud icons were showing for all my Notes Plus files.

Then I turned on the Automatic Download in Auto backup in Notes Plus settings and all the Notebooks downloaded from iCloud and I then saw that the 1.6 GB of iCloud Storage used for Notes Plus on the iPad. I completed all that about a day or two before I sent the initial message to you here as I waited to see if iCloud would eventually update to show up on my non iOS devices.

And looking now within the Notes Plus Section of iCloud Manage Storage I can descend down into the various Folders of my notebooks and I see the .npn files shown with their appropriate storage amounts.

This is on the Newer iPad that I just migrated(entire iPad) to. Of course on the older iPad the same amount is shown for Notes Plus in the iCloud Manage Storage Settings(~1.6 GB). What is odd about the older iPad is that it shows a large amount of storage being used for the Notes Plus App like about 777mb instead of the smaller amount that I have seen while previously ( in 6.0 and 5.6) using Note Plus iCloud Auto Backup. So I assume something went wrong after the initial move from 6.0 to 6.2.1 which I performed on the older iPad which migrated from the older format to the .npn format.

I am assuming there should have been a process launched by Notes Plus after the migration occurred on the older iPad that once the conversion was done and the new .npn files were safely uploaded back up to iCloud that the local files used for the conversion would have been deleted and the Storage size for the Notes Plus app should have dropped to around 150 MB.

So I saw a tip online that I tried regarding Folders not showing up in iCloud on MacOS and I went into my MacOS settings and turned off “Optimize Mac Storage”. At that same Dialog Settings>>iCloud>>iCloud Drive >> …Options I was sorry that I did not see a listing for NotesPlus in the Documents Tab where it said “Apps that store documents in iCloud will appear here”. Would have been nice if it was and all I needed to do was check the checkbox to make Notes Plus Folder to show up. ;-(

So after I turned off the Optimize Mac storage option I did notice when I was looking at the Get Info for the iCloud Drive folder in the Finder that it had initially shown the Drive size as around 1.92GB at the top of the dialog whereas below where it stated the Size on Disk to only be a few hundred megs but within a few minutes after turning off Optimize Mac Storage the size on disk went up to about 2GB.

Now a few hours after that, again giving iCloud a little while to settle, I still do not see the Notes Plus Beta Folder in the iCloud folder in the Finder. But…

If I open the Terminal and goto the ~/Library/Mobile Documents I do see a directory called iCloud~com~viettran~NotePlus and inside that the Documents Directory and inside that the Notebooks Directory with all my Notebooks.

One curious thing I am seeing though is that the actual notebooks do not appear as .npn files (packages) instead they just show up as directories which I can navigate into with the terminal and can confirm that all the Notebooks and their Page.svg files are all there.

Since I have managed to duplicate all the notebooks to a backup copy on a separate drive I guess my next step is to just remove the Notes Plus App and Data from the iPad and reinstall it without data and then re-migrate the data back into the App hoping things will go better this time?

I am also going to reset the older iPad to Factory Defaults since I am sending it to Apple for ‘recycling’ so I may do that first to avoid issues due to having two iPads with very similar installs on them both running Notes Plus and using auto back up to iCloud.

[Update about 1 hour later] So I have made further examination of files that have been ‘restored’ to the local Mac Drive when I turned off Optimize Mac Storage. I struggled quite a while to get at the iCloud Notebooks Folder in Terminal to copy to a separate location using the command line. I assume it is as much my ignorance about using the terminal as anything that I could not make it work, but I ended up finding a creative approach of using terminal and Finder together to get a copy of the data onto a local drive. I tried about 30-40 variations of the cp command with and without sudo option and I just got errors saying the ‘directories I was trying to copy or it’s destination did not exist’.

But since I could see the files and their location I managed to get the right path to go in Finder so I would not keep getting redirected to the main iCloud folder when I tried to use the finders Go Goto Folder… option. I used this: ~/Library/Mobile Documents/Notes Plus/Notes Plus which I determined after navigating with terminal to directory ‘iCloud~com~viettran~NotePlus’ which is inside ~/Library/Mobile Documents. There I used a pwd command to show the directory and copied and pasted that into the Go>> Goto folder … Menu in Finder. ( interesting thing to note is that the folder is called Note Plus/ NotesPlus not Notes plus Beta as it is on the iPad).

After getting the folder to a separate drive and examining the contents in the finder I saw what was happening.

So where one hint is that the files did not show the .npn extension for the notebooks but instead they just showed as folders. The next hint was that the last 6 days I have synced the notes to iCloud on my new iPad were missing from this Notebooks Folder. So it turns out that even though the Mac synced 1.6GB of Notes Plus data from the iCloud Drive after I turned off the Optimize Mac Storage a day ago that the data it synced is the data from My older iPad before I did the update to 6.2.1. Not the data that is being synched from Notes Plus on my iPad in 6.2.1. On the iPad I can see if I go into the Settings iCloud Manage Storage that the newer files(last 6 days) are there on iCloud and are using the .npn format.

Bottom line is that the iPad is connecting to iCloud Drive with the newer set of files in .npn format and my Mac is syncing to data that was from before I updated to 6.2.1 …6 days ago.

[Update about 5 hours later]
I went ahead and removed whatever traces I could of the Notes Plus App and it’s associated data on both iPads I also removed all the Notebooks Directory contents on the Mac inside the ‘iCloud~com~viettran~NotePlus’ which is inside ~/Library/Mobile Documents which had a few gigs of old data that had been left behind after I updated to 6.2.1 last week.
So I started everything over from scratch as far as I can tell, and well the same problem persists. I still don’t See the Notes Plus Beta folder on Non iOS devices in iCloud Drive.
I did go ahead and added the Folders with the Notebooks I had previously converted to .npn format. I had moved them out of the old installation to another Folder in iCloud Drive using the Files app and then I just moved these folders back in to the new install again using the Files app.
Again the longest part of this was the uploading of the files from the iPad up to iCLoud Drive after I moved the Notebooks into the Notes Plus iCloud Drive Folder( location).
And yes I do see the Note Plus Folder( in iOS with the Files App in iCloud Drive Location). I also see that my Note Plus data is on iCloud by looking both at the Settings in iOS on the IPad Manage iCloud Storage.

Stranger still I see this as well in the Mac System Preferences> iCloud> Manage Storage. In both places there is about 1.1 GB of data used by Notes Plus on iCloud Drive.

But despite that I still see no Folder for Notes Plus Beta when I open the Finder and click on the iCloud Drive shortcut on the left side of the finder. And I still don’t see a listing inside the Mac System Preferences>iCLoud Documents Tab to enable/disable Notes Plus. On the PC( using iCloud App 10.4) also no Note Plus Beta Folder and in a browser visiting iCloud Drive no Note Plus Beta Folder.