[Bug Reports] Notes Plus Beta Build 6.1

#1

First off, thanks so much for participating on this beta testing cycle. I want to start this topic to post bug reported by users (sent via email) so other testers can see what’s goign on.

Feel free to add your bug reports into this thread (make sure you have signed up for an account in our community site). If you have any troubles with signing up or posting bugs here, just email us at support@notesplusapp.com for assistance.

#2

This bug report comes from @Simeon (our long-time beta tester since our early days).

Here you go.
After updating to the latest beta I did the App Reset step.
Turned off iCloud Sync to do the reset and then it pushed the folders back.

Here are a couple of screen shots.

Here are some screenshots of my iCloud Drive NotesPlus Beta Folder just for reference to show the folder structure.
I also tried a complete backup and restore from DropBox as well just to make sure I had an additional copy of my Notebook folder data.

Then, I rolled back to the released version of Notes Plus and was able to see all my notebooks as they were so it did not seem I lost any of my notebooks.

I just wanted to make sure I was able to recover and sort of start back at square one. The notebooks actually were recovered it seemed from the iCloud backup.

#3

Another one from Simeon:

Next test.

Ok, I just tried this:

  • Restored my original Notes Plus installation
  • All of the notebooks seemed to be there restored when iCloud sync was turned on. So it looks like the copies in my iCloud are preserved in the older format.
  • opened Test Flight and installed the most recent beta build (6.1.05)

*Results: When opening Notes Plus the notebooks were converted into the Folder structure as the earlier screenshots demonstrated.

I just wanted to do something to reproduce and see if it made a difference going from the release version to the latest beta.

#4

The latest build (6.1.07) seems to have fixed a lot of my issues.
I thought I was experiencing the same folder view bug as described above but all I had to do was scroll down a little to see the newly converted notebooks.

ICkoud does sync the notebooks in the older format as well and you can see some duplicates have been created. This is alright for testing purposes at the moment and you can always get the original notebooks back if you install the release version and do a new iCloud sync.

I love the idea of a simpler notebook file structure and continue to admire the hard work and vision of Viet and the entire Notes Plus team.

All the best,
Simeon

1 Like
#5

YI sent a report last night via TestFlight. And one in the middle of the cycle. The one last night was critical… didnt it arrived?

#6

I haven’t received your bug report. Could you please re-post it here so I can make sure if it’s fixed or not?

#7

The critical one was:

I switched my appstoreid to us for a download, then switched back. I guess a lot of people do this. When I switched back all my notebooks were gone. ( it would be better to not delete them if only the AppStore account is switched, and not the appleID ) then I synced them back, and they were all grayish. I couldn’t edit, open,or delete any one of them. So I had to go some lengths to get them back. I added a Dropbox account. Synced with that. Deleted Dropbox. Synced again with iCloud. Then they were fully restored…

Sorry for my bad English sir, I’m in a hurry and not a native speaker as well. I hope you understand what I mean.

Dear regards

#8

Did you mean you switch to US App Store by signed out of your current Apple ID and use a another Apple ID set for other country (i.e US)? This isn’t supposed to affect the data on iCloud, unless you go to iPad’s Settings > your iCloud and sign out of the current account, then switch to the new AppleID account.

You can go to iCloud Drive > NotesPlus on Files.app, do you see data showing fully?

A few screenshots how did you observe on Files.app or Notes Plus would help us a lot on identifying this issue!

Thanks @RenaToma for your information!

#9

Exactly. Only the AppStore ID and not the iCloud.

I can’t find the screenshot anymore. Maybe I deleted it. But it was like I said gray. Grayish. Not with the right contrast…

Found the screenshot I sent to you via TestFlight

https://share.icloud.com/photos/0f-AhT1qfzspR0ArOeTSOkbUA

1 Like
#10

Thanks. I’ve seen this a few times. Could you please quit the app from background mode (multitasking), then try to open and let’s know if it’s accessible normally?